Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Replaced batteries but it's still not working

Ivory Zorich Aug 11, 2017 02:21AM UTC

Hi there, the exclamation point was showing up on the thermostat, so I changed the batteries, and the AC is still not turning on even though the exclamation point is now gone from the screen. I double checked that I installed the batteries correctly and they are. I also made sure to use brand new Alkaline name brand batteries. What should be my next step to fix this?

Thank you!

Up -1 rated Down
Kathy Aug 17, 2017 07:49PM UTC Radio Thermostat Company of America Agent


Have you tried doing a rest on the thermostat? If not try that.

Also if you turn the fan to on does it come on?

Let me know.

We look froward to hearing from you.


Your Radio Thermostat Support Team

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
Invalid characters found